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1.  Introduction to SmartScan Label Link 3.0
SmartScan Label Link gives the user the ability to print labels with
barcodes and other data based on specified QuickBooks Items.  Items can
be selected individually or on a transaction-level basis, adding Items from a
given Purchase Order, Sales Order, or Invoice for printing.  Label Link
sends these items to label template software such as BarTender, to print
data exactly how the user desires.  The user can create multiple label
templates and specify how the formatted data appears on the printed labels
using the label template software, before printing out a label that matches
the needs of the company more closely than ever before.

What’s new in Label Link 3?  Label Link 3 allows transaction data to be
included on the label such as customer/vendor information, date,
transaction number, and edited item information.  Label Link 3 can also
print a Packing Slip type label.  By including multiple different Items on
one label, and by customizing the Fields that appear on that label, as well
as the appearance of the label itself, it is now possible to create custom
Packing Slips as part of the shipping process.

Getting Started
Make sure you have the following:

• SmartScan Label Link CD
• Mouse
• Label template software such as BarTender
• Printer
• (Optional): A custom field assigned in QuickBooks (see p. 4) for the

barcode number (SmartScan Custom Field Manager – installation and
instructions are on the Label Link CD – can expedite the process of
assigning barcode numbers to the Items once this field is created).

Startup Checklist
□ Install SmartScan Label Link (p. 3)
□ Set up QuickBooks permissions (p. 4)
□ Connect to Company File (p. 4)
□ Edit Label (p. 6)
□ Edit Fields (p. 8)
□ Add Items to List (p. 12)
□ Edit Label file in label template software (p. 14, 17)
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Installing SmartScan Label Link
Contact Baus Systems for software download instructions or insert the
SmartScan Label Link CD into the computer CD drive.  The SmartScan
Label Link Setup Wizard will appear.  Follow the screens and use the
default settings, except change the installation to “Everyone”.

Registering SmartScan Label Link
Whenever SmartScan Label Link is opened prior to being registered, the
“Register with Baus Systems, L.L.C.” window appears.  Clicking “Skip
Registration” will proceed with the demo installation, but to continue
past the trial period, the program will need to be registered:
1. Enter your company name and the copy number you received on the

CD cover.
2. Click Register Now.
3. When the Registration Information window appears, send the Key1

and Key2 information to Baus Systems, L.L.C.
4. A copy of this information can be printed out by pressing the Print

button.
5. Enter the Activation Code given to you by Baus Systems, L.L.C.
6. Click “Done” to close the Registration Information dialog box.
7. Verify that your copy is now registered.  The message should say

“Registered to: (your company)”
8. Click “Done.”
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Working with QuickBooks
SmartScan Label Link connects with the QuickBooks Company file to get
transaction and Item information.  If a separate barcode field is needed,
then the Company file must have a custom field specified for this purpose.
Also, QuickBooks must be configured to grant permission for SmartScan
Label Link to access the Company file.

Adding a Barcode Field to QuickBooks
To add a barcode/scan code field to QuickBooks:
1. Start QuickBooks and log in as “Admin” in Single User Mode.
2. Click the Item List Icon.
3. Double click any Item.
4. Click .
5. Click  in the popup.
6. Enter a name for your barcode/scan code field in one of the unused

text boxes.
7. Check the check box next to the name you just entered:

.
8. Click .
9. Enter the barcode numbers in the barcode/scan code field.
10. Click .
11. Click .
12. Repeat steps 3, 4, and 9-11 for each Item in the list.

Decreasing QuickBooks Access Time
You can decrease QuickBooks access time by having your QuickBooks
Company file open on the computer on which you are running SmartScan
Label Link.

Setup Permissions in QuickBooks
Log  into QuickBooks in Single User Mode as “Admin” to set
permissions for SmartScan Label Link to access the Company file.  In
Label Link, select from the menu: File ► Open New Company.  The
following message will appear in QuickBooks for you to grant access
permission for Label Link:
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1. Choose “Yes, always; allow access even if QuickBooks is not
running” and set “Login as:” to Admin if this option is available (if it
is not available, skip to step 4).  Click Continue.

2. Confirm to Proceed: “Are you sure you want to allow this access?”
Click Yes.

3. Access Confirmation: Click Done
4. Label Link will now bring up a dialog box asking if you want to

update your lists now.  Click Yes to import your Item and Transaction
data to Label Link.

5. In QuickBooks, select the menu item Company ►Modify Service
Access.  If this option is not available, select Edit ► Preferences
instead.

6. Selected Integrated Applications from the manu on the left and switch
to the Company tab.

7. Select LabelLink and click Properties.
8. Check the boxes that allow the application to access QuickBooks and

auto-login as Admin.
9. Click OK, then OK again.  When this is complete, you may log out of

Single User Mode or close QuickBooks.

Setting New Company File
If at any time Label Link is not connected to the current Company file, the
Company file currently open in QuickBooks can be accessed as follows:
1. Open the Company File in QuickBooks
2. In LabelLink, select File ► Open New Company.
3. Click OK.
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2. Using SmartScan Label Link

Working with Label templates
Before printing any labels, you need to select a Label template from the
Current Label Template drop-down menu for Label Link to use when
printing labels.

Adding a Label template
If there are no Label templates on this list, or if you have a new template
that needs to be added to the list, select the <Add New Label Template….>
option.  This will bring up the “Add New Label Template” dialog box:

This dialog provides options for naming the label, selecting whether the
label is a BarTender or Wasp label, opening the label template in the
associated Labeler, setting the number of Items that will be printed on each
label, and specifying whether Items with more than one quantity selected
will be printed out multiple times, or just once with a quantity specified.
Clicking the Browse button will allow you to browse for the desired label
template to associate with Label Link.  When all the options are properly
configured, click the Add button to add the template to the list.
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Editing Label Templates
If a label that is already on the list needs to be modified, this can be done
by selecting the <Edit Label Templates….> option from the Current Label
Template drop-down menu, which will bring up the “Edit Label Template
Properties” window:

The “Edit Label Template Properties” window is the main launching point
for doing most activities involving the Label templates.  In addition to
providing a way to change the settings that were originally set through the
“Add New Label Template” dialog box, this window allows access to Field
Editor, discussed in the next section.  You can also add and delete Label
templates through this dialog.
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Working with Fields
SmartScan Label Link 3 provides a much more robust Field Editor than
previous releases of Label Link.  It is now possible to define any number of
specialty Fields for inclusion in custom Labels.  This section will contain a
brief discussion of some of the basic features of the Field Editor, but the
user is encouraged to experiment with our numerous options to find a style
most suited to the task at hand.  For an example, we will walk the user
through the creation of a Barcode Field.

Accessing the Field Editor
To access the Field Editor, select <Edit Label Templates…> from the
Current Label Template drop-down menu.  Select a Label template on the
Label list, and then click the Edit Fields button.  This will bring up the
“Edit (MyLabel) Fields” window:

This window has two lists of fields: Transaction level Fields, which use
data drawn from the Transaction (i.e., Invoice, Sales Order, or Purchase
Order) which adds a given Item to the list of Items to be printed; and Item
level Fields, which use data from the Item itself.  There are five columns in
a Field row which can be changed in this window:
1. Fields can be deleted by clicking the Delete button in the Field’s row.
2. The Type can be modified by the drop-down menu in the Type

column, which allows the Field to be specified as a Number, Date, or
Boolean (true/false value) type, or specified as Any, which means
that the Field could be any of the above.

3. The Edit button brings up the Formula Editor, which is discussed
below.

4. The Default Value (what appears in a Field if it has no value) can be
changed by clicking on the Default Value column for the Field and
entering a value.

5. The Length (the maximum number of characters that can appear in
the Field) can be changed by clicking on the up/down arrows in the
Length column.

For now, click on the Add New Field button at the bottom of the window to
bring up the Add New Field dialog box.
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Add New Field
The Add New Field dialog box allows the user to name and define a new
Field for use in the Label Link database for label printing.

For our Barcode field, change the name of the field to Barcode, and set the
Max Length to 10 – we don’t want to have too many characters showing up
in the barcode, after all.  Set the Default Value to “0000000000” so you can
easily tell if a barcode is invalid.  Then change the Field Data Type to Any.
It might seem more natural to set it to Number, but we actually want the
barcode to be a sequence of characters, since that’s how it will be treated
by the barcode printer.  If you’re not sure what type to make a Field, you
can still edit the Formula in the Formula Editor, and then Label Link will
decide what type the Field is.

Finally, click the Edit button after the Formula text box.  This will bring up
the Formula Editor, where you can choose the pieces of the Formula from a
list.  When you close the Formula Editor, your Formula will be
automatically inserted into the Formula text box.

The Formula Editor
The Formula Editor provides an interface for creating and editing the
Formulas that are used to generate Field values.  The Formula Editor
window consists of three main areas: The Formula definition area, the
Variables & Test Values area, and the Commands, Keywords & Operators
area.
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The Formula definition area

The Formula definition area shows the current text of the Formula you are
editing.  Typing is enabled in this area, so if you know how you want to
define the Formula, you can type it in directly, and you can change/remove
mistakes.

The Variables & Test Values area
The Variables & Test Values area
consists of a wide assortment of
Fields imported from QuickBooks
that can be added to the Formula.
When you click the Insert button next
to a variable, the name of the variable
is inserted into the Formula definition
area at the cursor position.  Test
values for the variable can be

modified by editing the entry in the Value column for the variable.  This
affects what appears in the Test area when the Test button is clicked while
the variable is included in the Formula (the Formula Editor doesn’t have
access to any data imported from QuickBooks, so this feature is important
in making sure your Formula works the way you expect it to).

The Commands, Keywords & Operators area
The Commands, Keywords & Operators area
contains functions and operators that allow the
user to modify what appears as a result of using
the Formula.  This includes such operations as
performing mathematical operations on
numbers, inserting the current Date/Time,
simplifying, altering, or combining strings of
text, and having the Formula choose what to
display based on what is contained in variables.
Clicking the Insert button next to an item inserts
that item into the Formula definition area at the
cursor position (additionally, if there is a block of text selected in the
Formula definition area and the parentheses or quotation operators are
selected, then the parentheses/quotes are inserted around the selected text).
For information about what a given item does, hover the mouse pointer
over the item.
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Other areas
The Test area is also of note.
This area, situated just under
the Formula definition area, allows you to test whether the Formula you
have entered is working the way you expect it to.  To test your Formula,
click Test.  The Formula Editor will then parse the Formula using whatever
values you have specified as test values for the variables you are using.

The final area of note is the Default Output area.  It is possible that, in the
processing of a Formula, one of the inputs to the Formula might be invalid
and cause the Formula to fail.  In this case, the Formula will return the
value specified by the Default Output.  To change this output, input a
Formula that gives the output you want to be the default and click Test.
When the outcome appears in the Test area, click the Set button, and the

Default Output value will
be set to the value in the
Test area.

To continue our barcode Field example, scroll down in the Variables &
Test Values area until you get to Item_[Your Barcode Custom Field] (if
you can’t see the Variables & Test values area, click the button “<<
Variables & Commands” to show it).  Click the Insert button in the barcode
row to insert the variable’s name into the Formula definition area.  Click
Test, and the Test value for the barcode will appear in the Test area.  Click
Ok when you’re done to finish.
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Printing Labels
When Label Link is connected to the QuickBooks Company file and a
Label Template is selected for printing, you are now ready to add Items to
the list of Items to be printed.  There are two ways to do this: you can add
Items individually, or from QuickBooks Transactions.

Adding Items Individually
To add Items individually, first make sure you are on the “Items to Be
Printed” tab of the main window.

In the Add Labels Type dropdown menu, select either Sales Item or
Purchase Item.  This affects what Fields are imported for prices and
descriptions of the Items, and whether the Item will be associated with a
Customer or a Vendor.  Click Add Items to bring up the Add Items
window.

This window contains a list of all the Items imported from QuickBooks,
with their Description and the quantity to be printed.  The quantity to be
printed starts at 0 for all Items.  You can change the number of labels to be
printed for an Item by typing in the quantity in the Qty column, or by
clicking the Up/Down arrows next to the Qty column.  You can also
associate all the Items entered here with a particular Customer/Vendor by
selecting the desired Customer/Vendor from the dropdown menu at the top
of the window.



SmartScan Label Link 3.0 for QuickBooks

Adding Items from Transactions
To add Items from Transactions, first go to the “Transaction Lists” tab of
the main window.

Select from the Transaction Type dropdown menu the type of QuickBooks
transaction you want to load Items from – either Invoice, PO (Purchase
Order), or SO (Sales Order).  Then click the Load button to import the
Transaction data from QuickBooks.

This will bring up the Transaction List Filter
dialog box, which allows you to specify
either a date range for Transactions to import,
or a particular Transaction number to import.
Select the Modified Date tab to enter a date
range, or select the Invoice Number tab to enter a specific Invoice Number.
Click Ok when finished to import the Transaction list.

The list of Transactions will now be populated with Transactions of the
specified type.  If there is any problem with the imported list, you can
reload the list by clicking the Reload button

To add all the Items from a Transaction to the list of Items to be printed,
select the Transaction and click the Add Items button.  This will send all of
the Items in the selected Transaction to the print list, and transfer the view
to the “Items to Be Printed” tab.

Printing Labels
Once the list of Items to be printed has Items in it, you can print by clicking
the Print button.  Alternately, you can click the Preview button to launch
the labeler software that uses the Label file associated with the Current
Label Template.  From within the labeler software, you can modify the
Label file to display the Fields you have specified in Label Link at the
locations you want on the labels.
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3. Using the Labeler Software
SmartScan Label Link currently supports two label printing programs:
BarTender and Wasp Labeler.  In this section, we will discuss how to
perform some commonly used tasks in each of these programs.

BarTender
When Print Preview is selected in Label Link with a BarTender label file
linked with the Current Label Template, Label Link will launch BarTender
with the current Item data.  The window that first appears contains the
template that BarTender uses for generating labels, not one of the labels
that will be printed.  It is on this template that you can select what data
from  Label Lin k is used to generate labels, as well as where it will appear
on the labels.

Creating Objects
Objects are what BarTender uses to display text, barcodes, and graphics on
labels.  To create an Object, right-click on an empty area on the label
template, select Create, and click the Object you want to create.  This will
place a new Object of the specified on the label template at the location you
clicked.  Barcode and Text Objects can be assigned constant data by
clicking on them and typing in the specified text, or they can be assigned
data from the Label Link database as described below.
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Modifying Barcode and Text Objects
Barcode and Text Objects can be modified to display data drawn from the
Label Link database, as well as static data that will display the same
regardless of the database contents.  To connect a Barcode or Text Object
with the Label Link database, double-click on the Object to bring up the
Modify Selected Object dialog box.  Select the Data Source tab, and then
select “Database Field” in the Source dropdown menu.  This will add the
Field Name dropdown menu to the Options section of the dialog box.
Select the Label Link Field you want this Object to display.

If the Object you are modifying is a Barcode Object, then the Human
Readable tab is also available.  This tab contains options to specify whether
a translation of the barcode will appear with the barcode, as well as where
this translation will appear with respect to the barcode.  To show Human
Readable text along with the barcode, go to the Human Readable tab and
select the Full option under Visibility.  You can then change the Placement
of this text to be either above or below the barcode, and change the
Alignment of the text to Left, Right, or Center Aligned, or Aligned to have
each character directly under the bars that translate to that character (Bar
Density).  Other options might also be available for certain barcode
symbologies, which can be selected on the Bar Code tab.

Other tabs in the Modify Selected Object dialog allow you to change the
Font and text size for the selected Object; manually change the position and
rotation of the Object; modify the Object’s name; and specify whether or
not the Object is to be included when labels are printed or viewed in the
Print Preview.  Feel free to experiment with the various different settings
exposed through this dialog box to get the labels looking the way you want.
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Connecting to the Label Link database
SmartScan Label Link comes with pre-made label files, already configured
to retrieve information from the Label Link database.  However, it is
possible that these files could accidentally be deleted or modified to no
longer access the Label Link database correctly.  If this happens, it will
become necessary to reconnect to the database manually.

To connect to the Label Link database, open the File menu and select
Database Connection Setup.  This will open the Database Connection
Setup dialog box:

If there are any entries under the All Databases entry in the box on the left
of the Database Connection Setup dialog box, select them and click the
Remove button to remove them from the list, until only the All Databases
entry remains.  Then click the Add button to bring up the Add Database
Connection Wizard.

The first screen of the Add Database Connection Wizard requests a
Database Platform.  Select Microsoft Access, and then click Next.  The
next screen requests a database name.  Click the Browse button to open the
Browse window and browse to the Label Link database location.  The
location of the Label Link database depends on whether you are using
Windows XP or Windows Vista.
Windows XP: Documents and Settings\All Users\Application Data\LabelLink3\Labels.mdb
Windows Vista: (Current User)\AppData\Local\VirtualStore\ProgramData\LabelLink3\Labels.mdb

Note: If any of the folders in Vista don’t appear, you might need
to set your Folder View settings to Show Hidden Files & Folders.  To do
this, open the Start Menu and select the Control Panel, then open Folder
Options.  Select the View tab, and change the “Hidden files and folders”
setting to “Show hidden files and folders.”

Click Next.  On the next screen, select the PrintOut table from the list on
the left, and then click the Add button to add it to the list on the right.
Click Finish to return to the Database Connection Setup dialog box, and
then click OK to return to the main window.
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Wasp Labeler
When Print Preview is selected in Label Link with a Wasp label file linked
with the Current Label Template, Label Link will launch Wasp with the
current Item data.  The window that first appears contains the template that
Wasp uses for generating labels, not one of the labels that will be
printed.  It is on this template that you can select what data from  Label
Lin k is used to generate labels, as well as where it will appear on the
labels.

Creating Objects
Objects are what Wasp uses to display text, barcodes, and graphics on
labels.  To create an Object, select the Object type you want to create from
the Object toolbar to the left of the working area, and then click on the
label where you want the Object to appear.  This will create the specified
Object where you click, and open the Object Properties window so that you
can edit the Object.

Modifying Barcode and Text Objects
Barcode and Text Objects can
be modified to display data
drawn from the Label Link
database, as well as static data
that will display the same
regardless of the database
contents.  To connect a
Barcode or Text Object with
the Label Link database,
double-click on the Object to
bring up the Object Properties
dialog.  This dialog allows you
to make modifications to what
is displayed in the selected
Object.



SmartScan Label Link 3.0 for QuickBooks

The content of the selected Object can be changed on the Bar Code/Text
tab of the Object Properties dialog.  To set a constant value for what
appears in the Object, click in the Barcode/Text Value text box and type in
what you want to appear on the label.  This value will then appear on every
label that is printed, exactly as you type it in here.

To set an Object to get data from the Label Link database, click in the
Barcode/Text Value text box and then click the “…” button after the text
box.  This will bring up the Object Source dialog.

Select the Databases option on the Source Type tab, then click Next to go
to the Object-to-Column Mappings tab.  This tab contains a dropdown
menu that lists the Fields
available from the Label Link
database.  Select the Field you
want to appear in this Object
from the dropdown menu.  If
the Label Link Fields are not
listed, you might need to
reconnect the label file to the
Label Link database (p. 19).

Other options on the Object Properties dialog allow you to specify different
options relating to how the content of the Object is displayed.  Both Text
and Barcode Objects contain options for specifying the size and location of
the Object, and there are also options that are specific to the type of Object.
Text Objects allow you to specify the Font and Size of the text, as well as
whether or not the text should be all on one line or multiple lines.  Barcode
Objects allow you to specify the symbology, format, and compression of
the barcode, as well as whether and how human readable text should be
displayed.  Feel free to experiment with different settings for each Object
type.



SmartScan Label Link 3.0 for QuickBooks

Connecting to the Label Link database
SmartScan Label Link comes with pre-made label files, already configured
to retrieve information from the Label Link database.  However, it is
possible that these files could accidentally be deleted or modified to no
longer access the Label Link database correctly.  If this happens, it will
become necessary to reconnect to the database manually.

To connect to the Label Link database, open the Data menu and select
External Data Source Wizard.  This will open the External Data Source
Wizard dialog.

Click Next to go to the Sources tab, then select Access from the Source
Type dropdown menu.  Click the Browse button to open the Browse
window, and browse to the Label Link database location.  The location of
the Label Link database depends on whether you are using Windows XP or
Windows Vista.
Windows XP: Documents and Settings\All Users\Application Data\LabelLink3\Labels.mdb
Windows Vista: (Current User)\AppData\Local\VirtualStore\ProgramData\LabelLink3\Labels.mdb

Note: If any of the folders in Vista don’t appear, you might need
to set your Folder View settings to Show Hidden Files & Folders.  To do
this, open the Start Menu and select the Control Panel, then open Folder
Options.  Select the View tab, and change the “Hidden files and folders”
setting to “Show hidden files and folders.”
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After selecting this file, click Next until you get to the Tables tab.

Check the box next to the PrintOut table, and then click Next until you get
to the Selections tab.

Click the Select All button to add all the columns from the PrintOut table to
the list of columns Wasp will draw data from, and then click the Exit
Wizard button.



SmartScan Label Link 3.0 for QuickBooks

If the label contains Objects that are mapped to database fields, then a
dialog box will appear that you can dismiss by clicking OK, followed by
the Object-to-Column Mappings window.

This window lists all the Text/Barcode Objects that are no longer mapped
to a database field.  Map each of the Objects to a database field by selecting
the Object on the list, then selecting the database field to map from the
dropdown menu on the right.  When all the Objects are mapped to a
database field, click OK to return to the main screen.


